如何实现RouterOS发送邮件?

RouterOS

1 前言

Mikrotik RouterOS的功能确实十分强大,笔者今天初尝邮件发送功能,发现配置十分简单。

2 最佳实践

2.1 设置smtp

/tool e-mail set address=smtp.cmdschool.org port=587 from="will@cmdschool.org" user=will@cmdschool.org password=****** start-tls=yes

注:
address参数,指定smtp服务器的地址
port参数,指定smtp服务器的端口
from参数,指定发送邮件的源地址
user参数,指定发送的用户名
password参数,指定发送用户的密码
start-tls参数,指定使用安全tls发送

2.2 测试邮件发送

/tool e-mail send to="xxx@cmdschool.org" subject="test" body="test" start-tls=yes

注:
to参数,指定发送邮件的目标地址
subject参数,指定发送邮件的主题
body参数,指定发送邮件的信息主体
start-tls参数,指定使用安全tls发送

2.3 使用范例

如果你问笔者以上范例有什么用,那笔者可以告诉你基于RouterOS的强大脚本,我们可以做很多事情。
以下是笔者写一个发送路由器IP地址的范例来分享,
首先,我们需要获取接口的名称,

/ip address print

信息显示如下:

 [...]
 3 D 113.77.84.48/32    113.77.84.1     ChinaNet

如上所示,我们确认接口名称为“ChinaNet”
然后,我们就可以写脚本获取接口的公网IP地址并发送,详细如下,

{
:local ipaddr;
:set ipaddr [/ip address get [/ip address find interface=ChinaNet] address];
:set ipaddr [:pick $ipaddr 0 ([:len $ipaddr] -3)];
/tool e-mail send to="xxx@qq.com" subject="router ip address" body="router ip address: $ipaddr" start-tls=yes;
}

参阅文档:
=====================
https://wiki.mikrotik.com/wiki/Manual:Tools/email
https://www.cmdschool.org/archives/492

没有评论

发表评论

RouterOS
如何应对电信PPPOE用户24/48小时断线一次?

笔者家里有一台做测试的虚拟服务器,通过电信的100M光钎远程控制,有时候白天做实验的时候突然中断,经 …

RouterOS
如何实现RouterOS花生壳动态域名解析?

花生壳官方提供给用户的“如何在ROS中设置花生壳ddns(公网版)”错漏百出,根本无法使用。 为了解 …

RouterOS
1
如何熟悉Mikrotik RouterOS的脚本语法?

最近要写一个routeros的script,但对其语法十窍九通,故而整理此文,以作参阅。 同时也发扬 …